Cummins 4BT & Diesel Conversions Forums banner

21 - 24 of 24 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #23
Ok folks I need to get to the core of this issue. As I may have said I have a 4bd1t in a 99 suburban. It has colt cam, head studs, 30% over injectors and hx 30 turbo. Fresh rebuilt pump and injectors. Problem.... Somtimes it will blow white smoke on a take off and once you stop and go again it will change to black. My 1500 Chevy I had it in did the same thing. I have been all thru this motor. Power isn’t different when either black or white.. Oregon fuel injection rebuilt the pump.. They tried to tell me that’s the nature of those pumps.. I deleted the fuel pump on the side of the injection pump and put a plate over it. I also got rid of the factory fuel filter and went with an air dog fuel pump. Fuel pressure is set around 15 psi. That really cleans up the engine bay... Any input would be appreciated... I think it’s timing . Can those timing advancement things on the front of the pump go bad?
 

·
Registered
Joined
·
235 Posts
Are you in Oregon? I'd like to see the build. Post pics, that always gets people at least looking at your build.

I can't help much, but I like seeing problems and how they're solved. All I know is white smoke is excess unburnt fuel, black is excess burnt fuel.
Waaay back I drove a 40' boom/crane flatbed with a plugged air filter and I purposely floored it on the freeway back to the shop and it blew a white cloud that fogged all lanes for a quarter mile.
Stuff a 22yr old does.

Are you sure you have clean filters?
 
21 - 24 of 24 Posts
Top