Cummins 4BT & Diesel Conversions Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Hi all, I have recently got to the point on my Ram Charger with 4bta a Dodge 46RE trans 2WD where I can start driving it and I have a problem. I have no boost at any load. The engine starts fine, idles well even seems to run okay. I am only getting a little over 20 mpg and I have no boost. I have checked lift pump pressure and flow, turbo has the correct amount of clearance. I have removed the air cleaner piping. I am going to check valve clearance and injection pump timing. The truck has a 3" exhaust with a diesel muffler. I would greatly appreciate any ideas or suggestions.
 

·
Registered
Joined
·
454 Posts
did you try driving with out the muffler ? wouldn't need to be far, and you would soon know.
 

·
Super Moderator
Joined
·
8,864 Posts
The turbo should be spinning (not spooled up, but will be spinning) even at idle. If it's not then you have a problem.
 

·
Registered
Joined
·
44 Posts
How much black smoke?

What are the egts?

Does your gauge work?
 

·
Registered
Joined
·
225 Posts
Sounds like my truck did originally. Had to get on the throttle pretty hard for boost and even then wasnt much. Discovered that some time in the past an air filter got wet and failed, went through the turbo, and was clogging the JWAC aftercooler. If yours has the JWAC, pull the inlet neck and look in at the heat exchanger. Its a longshot but you never know.
Carl
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #9 ·
Ram Charger Help

Thanks, I may have found the same problem. I found some boost , about 3 psi @ 1500 rpm no load , before the intercooler .
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #10 ·
I found it

Turbo bearing housing had been run loose and bearing housing was wore out. The turbine housing was wore out also. Well I now know why there was no boost it was all going out the center. If anybody is interested I have just completed a 1989 Dodge Ram Charger to 4BT swap. Even with no boost it ran very well. I am excited about getting running with the new turbo.
 

·
Registered
Joined
·
197 Posts
Well, are you gonna post some pics at Buildup threads now?
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #12 ·
1/2ton 2wd Ramcharger

I have few pics. I am going to wait till I have been able to run it a week or so.
I did this using all dodge 6bt parts and original R/C parts. Very little custom work. I'll put together a log with the pictures.
 
1 - 12 of 12 Posts
Top