Cummins 4BT & Diesel Conversions Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
1,203 Posts
Discussion Starter · #1 ·
this is starting to piss me off. I get a terrible squeal coming from the belt at ALL times, not when first started, not when AC kicks in, all the time. It's so loud that i've pulled over to check on it when it went away randomly for a few minutes, i thought i'd blown the belt.

I had a bent crank pully, now i replaced that with a 6bt ballancer. it was much better for a little bit, but now it's back. It looks like it rotates straight, but it still squeels like crazy.

Anyone got any ideas? Should i just try a new belt and see if that's better?
 

·
Registered
Joined
·
258 Posts
What condition is the belt and tensioner in? Is the belt glazed over on either side? If its glazed, it won't grip the pulleys and will slip. Check the tensioner tension to see if it is holding the belt tight. If the belt and tensioner look good, remove the belt and spin all of the pulleys to see if you have any bad bearings, or if any drag. There should be no looseness in any, and they should all spin smoothly. Spin the alternator to make sure it doesn't squeek when you spin it. You could have a bad alternator, and I've heard them that squeel just like a slipping belt.

Jim
 

·
Registered
Joined
·
1,203 Posts
Discussion Starter · #3 ·
i've sprayed that belt conditioner on the belt, that seemed to help but it comes back right away. I'm guessing maybe it lubes it so that it slips or something? The tensioner is in good shape. I am going to try and figure out what belt i need (search on here) and order one, i could use a spare anyways. It may be glazed, not sure. I thought it was in good shape though...not cracked iirc.
 

·
Registered
Joined
·
238 Posts
I had the alternator nut back off on my truck (brand new alternator) and the squeeling noise was the pulley and the fan slipping on the shaft.

caught that one quick, thank god.
-Scotty
 

·
Registered
Joined
·
390 Posts
When I did my conversion I had the same problem. Do you have a picture of how your belt routing is. Mine didn't have enough belt contact on the Alternator and the draw that I had on my alternator made the belt slip on the pulley. you need at least 1/2 of the pulley covered for the alternator, A/C Compressor the water pump can get away with 1/3 coverage. Do you have a belt driven fan or is it electric? Like everyone else says is your belt tensioner good?

my .02¢

my96z
 

·
Registered
Joined
·
854 Posts
Just as an FYI, Napa has a lifetime guarantee on their belts. Mine is a 080570 (8 ribs by 57")
 

·
Registered
Joined
·
1,203 Posts
Discussion Starter · #11 ·

·
Banned
Joined
·
427 Posts
you,ve got a bearing bad in the water pump,belt tensioner, alternator, a/c compressor etc. better take belt off and spin everything to find it...
bob
 

·
Registered
Joined
·
1,203 Posts
Discussion Starter · #14 ·
I agree completly with Bob, look for the problem that cooked the belt
i had a bent crank pully. fixed that with a new one. just have to figure out what belt i need, i'm away from the durango until saturday, i will just take it with me if i can't find the PN i need.
 
1 - 14 of 14 Posts
Top